OpenPLC缓冲区溢出漏洞


基本信息

时间: 2019-05-09

风险等级: 高

CNVD: CNVD-2019-13413

原地址: https://www.cnvd.org.cn/flaw/show/CNVD-2019-13413


描述
OpenPLC是一款开源的可编程逻辑控制器。OpenPLC_v2版本和OpenPLC_v3版本中存在缓冲区溢出漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。
产品
OpenPLCOpenPLCOpenPLC_v2OpenPLCOpenPLCOpenPLC_v3
解决方案
厂商尚未提供漏洞修复方案,请关注厂商主页更新:https://www.openplcproject.com/
CVE
CVE-2018-20818
来源
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20818